libcurl依赖问题


(panp85) #1

编译siren,发现无libcurl,需要移植:
make: *** 没有规则可以创建“out/target/product/rk312x/obj/SHARED_LIBRARIES/libbsiren_intermediates/import_includes”需要的目标“out/target/product/rk312x/obj/SHARED_LIBRARIES/libcurl_intermediates/export_includes”。 停止。
请问是否有现成的方案安装这个库?


(薯) #2

刚刚更新了blacksiren,请同步一下再试试


(panp85) #3

更新代码后如下:
make: *** 没有规则可以创建“out/target/product/rk312x/obj/SHARED_LIBRARIES/libbsiren_intermediates/import_includes”需要的目标“out/target/product/rk312x/obj/SHARED_LIBRARIES/libcurl_intermediates/export_includes”。 停止。
make:离开目录“/mnt/onego/panpan/L110-first”


(薯) #4

稍等,我想办法解决一下


(panp85) #5

我用的android6.0工程下编译的,这个工程没有externel/curl依赖库


(qijiasi001) #6

您的android aosp工程的external下面没有curl是吗?


(panp85) #7

是的


(qijiasi001) #8

我建议您同步一个aosp6.0的干净代码,然后将相关依赖加进您的工程,可以使用清华的源,速度挺快的。

https://mirrors.tuna.tsinghua.edu.cn/help/AOSP/

如果仍然有问题,我们很快会直接提供so